inux 安装rpm包时遇到error:Failed dependencies解法方法 2

环境:Centos 5.5 + MySQL-server-5.5.24-1.linux2.6.x86_64.rpm
遇到的问题:

[root@sh158-xen data]#rpm -ivh MySQL-server-5.5.24-1.linux2.6.x86_64.rpm
error: Failed dependencies:
 
        MySQL conflicts with mysql-5.0.77-4.el5_4.2.x86_64

纠结了半天,终于找到了解决方法:(感谢提供相关文章的博友)
在安装包后面加两个参数,如

[root@sh158-xen data]#rpm -ivh MySQL-server-5.5.24-1.linux2.6.x86_64.rpm --nodeps --force
Preparing...                ########################################### [100%]
   1:MySQL-server           ########################################### [100%]

加上那两个参数的意义就在于,
安装时不再分析包之间的依赖关系而直接安装,
也就不会再提示error: Failed dependencies:这样的错误了

还没有评论,快来抢沙发!

发表评论

  • 😉
  • 😐
  • 😡
  • 😈
  • 🙂
  • 😯
  • 🙁
  • 🙄
  • 😛
  • 😳
  • 😮
  • emoji-mrgree
  • 😆
  • 💡
  • 😀
  • 👿
  • 😥
  • 😎
  • ➡
  • 😕
  • ❓
  • ❗
  • 69 queries in 0.405 seconds